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R version 3.4.1 (2017-06-30) -- "Single Candle"
Copyright (C) 2017 The R Foundation for Statistical Computing
Platform: x86_64-w64-mingw32/x64 (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
‘citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, ‘help()' for on-line help, or
'help.start()' for an HTML browser interface to help.

Type 'q()' to quit R.
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R version 3.4.1 (2017-06-30) -- "Single Candle"
Copyright (C) 2017 The R Foundation for Statistical Computing
Platform: x86_64-w64-mingw32/x64 (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.

You are welcome to redistribute it under certain conditions.

Type 'license()' or 'licence()' for distribution details.

R is a collaborative project with many contributors.
Type 'contributors()' for more information and

‘citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, ‘'help()' for on-line help, or

‘help.start()' for an HTML browser interface to help.
Type 'q()' to quit R.
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RStudio Cheat Sheet

RStudio IDE

Documents and Apps
0@ Open Shiny, R Markdow
IXTEX | knitr, Sweave, LaTeX, Rd'nes

and more in S'x.u(r‘ Pane

Check  Render Choose Choose Insert
spelling output output output code
3 format location chunk
Jumpto Jump” Run Publish * Show file|
previous tonext selected toserver outline
chunk  chunk lines

Access markdown guide at
Help> Markdown Quick Reference
Runthisand Run this

2 Jumpto Setknitr
chunk

1B chunk allprevious  code chunk
u options  code chunks

16 H T i

177 {r prissure, echosFALSE} 2y

18 plot(prebsure)
1 H
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Write Code R Support

RStudio recognizes that fles named app.
server.R. ui.R. nd global.R belong washwy awp_

[rr=r=rarr—ps
3z >

1 z

2 Run""Choose "“Bublishto - Manage

3 app locationto shinyappsio publish

H viewapp orserver  accounts,

Debug Mode

debugger

Navigate Openinnew Save Findand Compileas Run Importdata  History o past Dl\]L.yQPrm\vdmhuN\
tabs window replace  notebook  selected  withwizard  commandsto  File> N
- ~code run/copy RPresentation
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Version Control wincitorsun

Launch debugger  Open traceback to examine

-+~

Turn o1 a1 Tools > Project Options > Git/SVN

Click next to'
line number to'
add/remove a

Open with debug(), browse(), or a breakpoint. RStudiovill open the  mode from origin nctions that R called = pull
g(), browse(, or o br Stud n th e LRl Stage  Showfile Commit  Push/Pull yiew
mode whenit encounters a breakpoint while executing code.  of efror occurred [(G) e d sageres oremete_Hior
ot Comtole =/ Dicheatshes =0 M Added o o]
> foo0) Deleted o
Voo PE " s
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Highlighte
line show
where
execution has
paused

Console ~/IDEches t

T | Package Writing

@=Next [} 4= P Continue

Runcommandsin  Examinevariables
environmentwhere  in executing
execution has paused  environment

@ studio
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Select function St
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oo .. Download:
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Pro Features

Share Project  Active shared

with Collaborators... collaborators
: Start new R Session

__incurrent project

£ CloseR

T w3z, | Sessionin
Rverson 3,03 ) Project
Rran303 [ Salact
| et | "R versis
[ PROJECT SYSTEM
File > New Project

RStudio saves the call history,
workspace, and woring
directory associated with a
project. It reloads each when
You re-open a project.

Name of
current project

RStudio opens plots in 2 dedicated Plots pane

(O
b e 2o muem o g e
Navigate “Openin ~Export " Delete "~ Delete
recentplots_window _plot __plot___all plots

GUI Package manager lists every installed package

T o s v
et @uoeme re,

Install  Update ~ Create reproduc blepaclage
Packages. Packages libraryfor your poject

Delete

Click to load package with Package
library(). Unclick to detach version  from
package with detach() installed library

RStudio opens documentation in a dedicated Help pane

T g

Search for

nepageofl  Searchwithin
file

helpful links help file help

t, such as Shiny apps,
ractive visualizations

Viewer Pane displays HTML cont
RMarkdown reports, and inte
v

S
Publish to shinyapps.io,  Refresh

Stop Shiny
aon coubs BSCongect

https://resourcés.rstudio.com/rstudio-cheatsheets/

rstudio-ide-cheat-sheet

RStudio® is a tradent =
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RER{E
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get_area <- function(r = 1) { [l

area <- 3.14 *x ¥ % ¥

Apoq

return(area)
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Function Arguments



fun <- function(pl, p2, p3) ...}

fun(1, 2, = 3)

1. i8Ik E A FH (Named) Arguments

2. BRF15/kFEIT#I Arguments
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pl P2 p3
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fun(1, 2,

87K 2nd
Unnamed Argument
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e Basic unitsin R
e length()

o 47 (RERR)EE
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Integer
Double
Logical
Character

Vector



Element-wise operation
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Logical Operators

Operator e =

> a>bh a Xmib?

>= a>=b a KIRsFERDb?
< ac<bh a/hMib?

<= a<=bh a /MNREFERD?
== a == aZEib?

= al=h afrFERDb?

%in% a %in% c(a, b, c¢) aEhc(a b,c)?




Boolean Operators

Operator B =3

& condl & cond2 H (and)

| condl | cond2 g%, (or)

! !condl 3E (~)

any () any(condl, cond2, cond3, ...) Eh—(AAE?
all() all(condl, cond2, cond3, ...) *AHEE?

xor () xor(condl, cond2) cond1 £ cond2 EF—EAEE?
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Rules of Coercion

logical

TRUE - 1
FALSE —. O

numeric

more

general ' character




Subsetting a vector
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vec

vec[3]
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vec["Bob"] vec[e( T , F, T, F)]
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(if-else)



print("x is positive")

t else 3

print("x equals zero")

||I'Wl



#O)
print("x is positive")

Pelse if ()

print("x is negative")

 |S1S8 ¢
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if (<fF&E 1>) {§

<Some Code>
H15 TRUE ECFALSE

? else if (<&EH 2>) ¢
<Some Code> RA—EERE AT

t else 3

<Some Code>



R Markdown






R Markdown R9$51#

File --> New File --> R Markdown...

% N -] Knit ~ -

title: "Untitled"
author: "Yongfu Liao"
date: "9/18/2019"
output: html_document

yaml:
PRI S8 C

- ## R Markdown

i
2
3
4
5
6
7
8
9
0

1

Markdown is a simple formatting syntax for authoring
HTML, PDF, and MS Word documents. For more details on
using R Markdown see <http://rmarkdown.rstudio.com>.

R Code Chunk: j_(r cars} Markdown
AT R EEMEL SUTmAryRears N

- ## Including Plots

You can also embed plots, for example:




' R Markdown

® @® RStudio Source

& | test.Rmd °
= & Knit
L

p3

1 (- f——

2 title: "Hello R Markdow

3 author: "Awesome Me"

4 date: "2018-02-14"

5 output: html_document

6 s

7

8 This is a paragraph in an R Markdown document.
9

10 Below is a code chunk:

11

12~ *""{r}

13 fit = lm(dist ~ speed, data = cars

14 b = coef(fit)

15 plot(cars)

16 abline(fit)

17 o

18

19 The slope of the regression is "r b[1]"

J
]



R Markdown Cheat Sheet

R Markdown

What is R Markdown?

.Rmd files - An R Markdown
{:Rmd) fle is a record of your
research. It contains the code that a
scientist needs to reproduce your work
along with the narration that a reader
needs to understand your work
Reproducible Research - At the click of a
button, or the type of a command, you
can rerun the codein an R Markdown file
to reproduce your work and export the
results asa finished report.
Dynamic Documents - You can choose
xport the finished report in a variety
of formats, including html, pdf, MS
Word, or RTF documents; html or pdf
based lides, Notebooks, and more.

Workflow

o9

Sl e

) Open a new .Rmd file at File > New File -
; wizard that opens to pre-
populate the file with a template
) write document by editing template

 Knit amm.nm create report; use knit button or
render() to ki

©) Preview Output in IDE window

© publish (optional) to web server

(@ Examine build log in & Markdown console
@ Use output file that is saved along side Rmd.

CHEAT SHEET

A e - - &

title:

1
2 R Morkdom
3 author: "Rt
4 output

3 oot
6 toe: TR

7

8

{r setup, (nclude-FALSE}
10 knitr: :opts_chunkSset(echo - TRUE)
ks

ene -/Dtskwolﬂ—mvkaomvcncusnewrevon.mm\g
e i Tridn-

R Markdown

RStudio

« RMarkdown

R Markdown

Reload document

This is an R Markdown document. Markdown is a simple

utling  formatting syntax for authoring HTML, PDF, and MS Word

documents.

.rmd Structure [QuEeEN

YAML Header
Optional section of render (e.g. pandoc)
options written as key:value pairs (YAML).

Atstart of file
Between linesof ---

Text
Narration formatted with markdown, mixed with:

Code Chunks
Chunks of embedded code. Each chunk:

Beginswith***{r}
endswith***

:z summary(cars) R Markdown will run the code and append the results to the doc.
13- ## R Morkdown of the .Rmd file

14

15 This 5 on R Markdown docurent. ¥

16 Narkéow 15 o steple foreotting P

17 syntox for authoring KTML, ” arameters

18 ond U5 Word documents "

19 ” Parameterize your documents to reuse with

20 **{r cors} B ” differentinputs (e.g., data, values, etc.)

21 sumorytears) -

- 1. Add parameters - (realeandsel P-Irams

2 parameters in the header -

24 For more details on using R Markdoan For more details on using R Markdown see values of params d w Sys Datef)
25 see <http://rmarkdown. rstudio.coms. hitp://rmarkdown. rstudio.com. %

1910 tvakdoun « varkdons! 2.Call parameters - Call parameter
Com  Markdown T Tl Pets Packages Welp  Viewer pre) Today's date

s is "r paramsSd

> Library(rmarkdonn)

> render(*report.Rnd", output.file - “report.htsl™)

render

Use rmarkdown:render() to render/knit at cmd line. Important args:

Embed code with knitr syntax

INLINE CODE

Insert with * r <code>". Results appear as text without code.

Built with *r getRversion( Built

IMPORTANT CHUNK OPTIONS

input. fletorender  output_options - output_file
List of render
output_format options (asnvauy)  CutPut.dir
CODE CHUNKS
One or more lines surrounded with * ** {r} and *. Place chunk
oRtiom withie ity beaces after . Insest Wit 3;

TRUE

cach for future knits (default = depend in fig.align - left, right, or ‘center’ (defauit =
FALSE) (a0 B E <
cache.path y results in h put document (default = fig.cap-fia:
(default ="cache/") TRUE) =NuL]
il e kit and = engine- (default=fig.heif
R) inches

pst collapse all output into single block error - Display error messages in doc (TRUE) or highlig
(dﬂaull = FALSE) stop render when errors occur (FALSE) (default = inclug
comment- prefix for each line of results (default =) FALSE) (defaul!

‘eval - Run code in chunk (default = TRUE)
Option:

@Studio

opt:
outextra, o

ot st

params - lst of

envir - environment
params to use de

encoding - of input
to evaluate coc file

GLOBAL OPTIONS
Setwith knitr:opts_chunk$set(), e.¢

rin SE
knitr::opts_chunkSset(echo = TRUE

){me messagesin
RUE)

message -
document [de?

Ldatault_caentte Lk

Download:
https://resources.rstudio.com/rstudio-cheatsh

3. Set parameters - Set values wth

Knit with parameters or the params
argument of render(: i
render("doc. Rmd", params = list(n =
d=as.Date("2015-01-01"))

Interactive
Documents

Turn your lvporl mlo an interactive Shiny
do(umenl in 4 ste

1.Add runtime: shmy to the YAML header.
2.Call Shiny input functions to embed input objects.

3. Call Shiny render functions to embed reactive output.

4 it orclick
RStudio IDE
How many cars?
output: html_document s
runtime: shiny

ol echo=FALSE}
numericinput{"n”
"How many cars?", 5) 5

da

eets/rmarkdown-2-0-cheat-sheet

RStudio® is a tradema
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